Excel посчитать количество ячеек со значением

Содержание

Синтаксис и использование функции СЧЕТЕСЛИ в Excel

Функция СЧЕТЕСЛИ в Excel используется для подсчета ячеек в пределах заданного диапазона, которые соответствуют определенному критерию или условию.

Например, вы можете использовать функцию СЧЕТЕСЛИ, чтобы узнать, сколько ячеек на вашем листе содержит число больше или меньше указанного вами числа. Другое типичное использование функции СЧЕТЕСЛИ в Excel – подсчет ячеек с определенным словом или началом с конкретной буквы (букв).

Синтаксис функции СЧЕТЕСЛИ очень прост:

Как видите, есть только 2 аргумента функции СЧЕТЕСЛИ, оба из которых обязательны:

  • диапазон – определяет одну или несколько ячеек для подсчета. Вы помещаете диапазон в формулу, как обычно, в Excel, например. A1:A20.
  • критерии – определяет условие, которое сообщает функции, которую подсчитывают ячейки. Это может быть число, текстовая строка, ссылка на ячейку или выражение (например, “10”, A2, “>=10”).

Вот простейший пример функции СЧЕТЕСЛИ в Excel. Формула =СЧЁТЕСЛИ(C2:C7;”Иванов Иван”) подсчитывает, сколько заявок поступало от Иванова Ивана:

Функция СЧЕТЕСЛИ в Excel – Пример использования функции СЧЕТЕСЛИ в Excel

Примечание : Критерий нечувствителен к регистру, что означает, что если вы наберете «иванов иван» в качестве критерия в приведенной выше формуле СЧЕТЕСЛИ, это приведет к такому же результату.

Статистический анализ посещаемости с помощью функции СЧЁТЕСЛИ в Excel

Пример 3. В таблице Excel хранятся данные о просмотрах страниц сайта за день пользователями. Определить число пользователей сайта за день, а также сколько раз за день на сайт заходили пользователи с логинами default и user_1.

Вид исходной таблицы:

Поскольку каждый пользователь имеет свой уникальный идентификатор в базе данных (Id), выполним расчет числа пользователей сайта за день по следующей формуле массива и для ее вычислений нажмем комбинацию клавиш Ctrl+Shift+Enter:

Выражение 1/СЧЁТЕСЛИ(A3:A20;A3:A20) возвращает массив дробных чисел 1/количество_вхождений, например, для пользователя с ником sam это значение равно 0,25 (4 вхождения). Общая сумма таких значений, вычисляемая функцией СУММ, соответствует количеству уникальных вхождений, то есть, числу пользователей на сайте. Полученное значение:

Для определения количества просмотренных страниц пользователями default и user_1 запишем формулу:

В результате расчета получим:

Подсчет ячеек в Excel, используя функции СЧЕТ и СЧЕТЕСЛИ

Очень часто при работе в Excel требуется подсчитать количество ячеек на рабочем листе. Это могут быть пустые или заполненные ячейки, содержащие только числовые значения, а в некоторых случаях, их содержимое должно отвечать определенным критериям. В этом уроке мы подробно разберем две основные функции Excel для подсчета данных – СЧЕТ и СЧЕТЕСЛИ, а также познакомимся с менее популярными – СЧЕТЗ, СЧИТАТЬПУСТОТЫ и СЧЕТЕСЛИМН.

Статистическая функция СЧЕТ подсчитывает количество ячеек в списке аргументов, которые содержат только числовые значения. Например, на рисунке ниже мы подсчитали количество ячеек в диапазоне, который полностью состоит из чисел:

В следующем примере в двух ячейках диапазона содержится текст. Как видите, функция СЧЕТ их игнорирует.

А вот ячейки, содержащие значения даты и времени, учитываются:

Функция СЧЕТ может подсчитывать количество ячеек сразу в нескольких несмежных диапазонах:

Если необходимо подсчитать количество непустых ячеек в диапазоне, то можно воспользоваться статистической функцией СЧЕТЗ. Непустыми считаются ячейки, содержащие текст, числовые значения, дату, время, а также логические значения ИСТИНА или ЛОЖЬ.

Решить обратную задачу, т.е. подсчитать количество пустых ячеек в Excel, Вы сможете, применив функцию СЧИТАТЬПУСТОТЫ:

Как посчитать количество заполненных и пустых ячеек в Excel

​ выборочных данных. В​ ячеек в​. Выделяем его и​ результата и запустили​ куда будут выводиться​Запускается окно аргументов. Аргументами​ после слова​ должны быть учтены.​СЧЁТЗ подсчитывает все ячейки,​ для считывания и​ нему в том​жмем на кнопку​. Ищем значение​. Её синтаксис выглядит​Ctrl​ строк. При их​

Функция СЧЁТ, СЧЁТЗ и СЧИТАТЬПУСТОТЫ для подсчета ячеек в Excel

​На вкладке​ формулах можно применять​Excel по условию​ жмем на кнопку​

​ Мастер функций, выбираем​ данные и таким​ этой функции являются​«Количество»​ Заранее спасибо​ которые не пустые.​ подсчета значений в​ столбце, где было​«Условное форматирование»​«ЧСТРОК»​ следующим образом:​кликаем по заполненным​ использовании применяются различные​Формулы​ специальные символы, чтобы​, как посчитать не​

Принцип счета ячеек функциями СЧЁТ, СЧЁТЗ и СЧИТАТЬПУСТОТЫ

​ запись​ же способом запускаем​ ссылки на ячейки.​.​Михаил С.​ Данную функцию удобно​ диапазоне ячеек: СЧЁТ(),​ проведено форматирование. В​. Выбираем пункт​, выделяем его и​=ЧСТРОК(массив)​ ячейкам, в тех​ инструменты. Поэтому нужно​щелкните​

​ выбрать определенные данные.​ все ячейки, а​.​«СЧЁТЕСЛИ»​ Мастер функций. В​ Ссылку на диапазон​Но, хотя по умолчанию​: =СЧЁТЕСЛИ(B2:B29;»<>0″)​ использовать в том​ СЧЁТЗ и СЧИТАТЬПУСТОТЫ.​ открывшемся меню выбираем​«Правила выделения ячеек»​ жмем на кнопку​Её можно вбить в​ строчках, которые оказались​ смотреть конкретный случай,​Вставить​

​ Как это сделать,​ выборочно.​Происходит открытие окна аргументов.​. Кликаем по кнопке​ нём выбираем оператора​ можно прописать вручную,​ этот счетчик включен,​vikttur​ случаи, когда необходимо​ Каждая из этих​ пункт​. Далее открывается пункт​«OK»​ любую пустую ячейку​

​ пустыми в выделенной​ чтобы выбрать более​, наведите указатель мыши​ смотрите в статье​У нас такая​ Собственно, аргументы функции​«OK»​ с наименованием​ но лучше установить​ и только ждет​

exceltable.com>

Статистический анализ посещаемости с помощью функции СЧЁТЕСЛИ в Excel

Пример 3. В таблице Excel хранятся данные о просмотрах страниц сайта за день пользователями. Определить число пользователей сайта за день, а также сколько раз за день на сайт заходили пользователи с логинами default и user_1.

Вид исходной таблицы:

Поскольку каждый пользователь имеет свой уникальный идентификатор в базе данных (Id), выполним расчет числа пользователей сайта за день по следующей формуле массива и для ее вычислений нажмем комбинацию клавиш Ctrl+Shift+Enter:

Выражение 1/СЧЁТЕСЛИ(A3:A20;A3:A20) возвращает массив дробных чисел 1/количество_вхождений, например, для пользователя с ником sam это значение равно 0,25 (4 вхождения). Общая сумма таких значений, вычисляемая функцией СУММ, соответствует количеству уникальных вхождений, то есть, числу пользователей на сайте. Полученное значение:

Для определения количества просмотренных страниц пользователями default и user_1 запишем формулу:

В результате расчета получим:

С определенным текстом или значением

С определенным текстом или значением

Функция СЧЁТЕСЛИ – позволяет рассчитать количество блоков, которые соответствуют заданному критерию. В качестве аргумента прописывается диапазон – В2:В13 , и через «;» указывается критерий – «>5» .

Например, есть таблица, в которой указано, сколько килограмм определенного товара было продано за день. Посчитаем, сколько товаров было продано весом больше 5 килограмм. Для этого нужно посчитать сколько блоков в столбце Вес, где значение больше пяти. Функция будет выглядеть следующим образом: =СЧЁТЕСЛИ(В2:В13;»>5″) . Она рассчитает количество блоков, содержимое в которых больше пяти.

Для того чтобы растянуть функцию на другие блоки, и скажем поменять условия, необходимо закрепить выбранный диапазон. Сделать Вы это сможете, используя абсолютные ссылки в Excel.

Функция также может рассчитать:

– количество ячеек с отрицательными значениями: =СЧЁТЕСЛИ(В2:В13;» ; – количество блоков, содержимое в которых больше (меньше) чем в А10 (для примера): =СЧЁТЕСЛИ(В2:В13;»>»&A10) ; – ячейки, значение в которых больше 0: =СЧЁТЕСЛИ(В2:В13;»>0″) ; – непустые блоки из выделенного диапазона: =СЧЁТЕСЛИ(В2:В13;»») .

Применять функцию СЧЁТЕСЛИ можно и для расчета ячеек в Excel, содержащих текст. Например, рассчитаем, сколько в таблице фруктов. Выделим область и в качестве критерия укажем «фрукт». Будут посчитаны все блоки, с данным словом. Можно не писать текст, а просто выделить прямоугольник, который его содержит, например С2 .

Для формулы СЧЁТЕСЛИ регистр не имеет значения, будут подсчитаны ячейки содержащие текст «Фрукт» и «фрукт».

В качестве критерия также можно использовать специальные символы: «*» и «?» . Они применяются только к тексту.

Посчитаем сколько товаров начинается на букву А: «А*» . Если указать «абрикос*» , то учтутся все товары, которые начинаются с «абрикос»: абрикосовый сок, абрикосовое варенье, абрикосовый пирог.

Символом «?» можно заменить любую букву в слове. Написав в критерии «ф?укт» – учтутся слова фрукт, фуукт, фыукт.

Чтобы посчитать слова в ячейках, которые состоят из определенного количества букв, поставьте знаки вопросов подряд. Для подсчета товаров, в названии которых 5 букв, поставим в качестве критерия «. » .

Если в качестве критерия поставить звездочку, из выбранного диапазона будут посчитаны все блоки, содержащие текст.

Особенности использования функции СЧЁТЕСЛИ в Excel

Функция имеет следующую синтаксическую запись:

=СЧЕТЕСЛИ( диапазон; критерий )

  • диапазон – обязательный аргумент, принимающий ссылку на одну либо несколько ячеек, в которых требуется определить число совпадений с указанным критерием.
  • критерий – условие, согласно которому выполняется расчет количества совпадений в рассматриваемом диапазоне. Условием могут являться логическое выражение, числовое значение, текстовая строка, значение типа Дата, ссылка на ячейку.
  1. При подсчете числа вхождений в диапазон в соответствии с двумя различными условиями, диапазон ячеек можно рассматривать как множество, содержащее два и более непересекающихся подмножеств. Например, в таблице «Мебель» необходимо найти количество столов и стульев. Для вычислений используем выражение =СЧЁТЕСЛИ(B3:B200;”*стол*”)+СЧЁТЕСЛИ(B3:B200;”*стул*”).
  2. Если в качестве критерия указана текстовая строка, следует учитывать, что регистр символов не имеет значения. Например, функция СЧЁТЕСЛИ(A1:A2;”Петров”) вернет значение 2, если в ячейках A1 и A2 записаны строки «петров» и «Петров» соответственно.
  3. Если в качестве аргумента критерий передана ссылка на пустую ячейку или пустая строка «», результат вычисления для любого диапазона ячеек будет числовое значение 0 (нуль).
  4. Функция может быть использована в качестве формулы массива, если требуется выполнить расчет числа ячеек с данными, удовлетворяющим сразу нескольким критериям. Данная особенность будет рассмотрена в одном из примеров.
  5. Рассматриваемая функция может быть использована для определения количества совпадений как по одному, так и сразу по нескольким критериям поиска. В последнем случае используют две и более функции СЧЁТЕСЛИ, возвращаемые результаты которых складывают или вычитают. Например, в ячейках A1:A10 хранится последовательность значений от 1 до 10. Для расчета количества ячеек с числами больше 3 и менее 8 необходимо выполнить следующие действия:
  • записать первую функцию СЧЁТЕСЛИ с критерием «>3»;
  • записать вторую функцию с критерием «>=8»;
  • определить разницу между возвращаемыми значениями =СЧЁТЕСЛИ(A1:10;”>3″)-СЧЁТЕСЛИ(A1:A10;”>=8″). То есть, вычесть из множества (3;+∞) подмножество [8;+∞).

Как в Excel суммировать ячейки только с определенным значением

Пример 3. В таблице указаны данные о зарплате сотрудника на протяжении 12 месяцев прошлого года. Рассчитать доходы работника за весенние месяцы.

Вид таблицы данных:

Весенними месяцами являются месяца с номерами 3, 4 и 5. Для расчета используем формулу:

Сумма зарплат с 6-го по 12-й месяц является подмножеством множества суммы зарплат с 3-го по 12-й месяц. Разница этих сумм является искомой величиной – суммой зарплат за весенние месяцы:

Функцию СУММЕСЛИ можно использовать если требуется определить сразу несколько значений для различных критериев. Например, для расчета суммы зарплат за три первых и три последних месяца в году соответственно составим следующую таблицу:

Для расчетов используем следующую формулу:

В результате получим:

Синтаксис и особенности функции

Сначала рассмотрим аргументы функции:

  • Диапазон – группа значений для анализа и подсчета (обязательный).
  • Критерий – условие, по которому нужно подсчитать ячейки (обязательный).

В диапазоне ячеек могут находиться текстовые, числовые значения, даты, массивы, ссылки на числа. Пустые ячейки функция игнорирует.

В качестве критерия может быть ссылка, число, текстовая строка, выражение. Функция СЧЕТЕСЛИ работает только с одним условием (по умолчанию). Но можно ее «заставить» проанализировать 2 критерия одновременно.

Рекомендации для правильной работы функции:

  • Если функция СЧЕТЕСЛИ ссылается на диапазон в другой книге, то необходимо, чтобы эта книга была открыта.
  • Аргумент «Критерий» нужно заключать в кавычки (кроме ссылок).
  • Функция не учитывает регистр текстовых значений.
  • При формулировании условия подсчета можно использовать подстановочные знаки. «?» – любой символ. «*» – любая последовательность символов. Чтобы формула искала непосредственно эти знаки, ставим перед ними знак тильды (

).

Для нормального функционирования формулы в ячейках с текстовыми значениями не должно пробелов или непечатаемых знаков.



Функция СЧЕТЕСЛИ в Excel – примеры

Синтаксис функции СЧЕТЕСЛИ очень прост, однако он допускает множество возможных вариантов критериев, включая подстановочные знаки, значения других ячеек и даже другие функции Excel.

Функция СЧЕТЕСЛИ в Excel для текста и чисел (точное совпадение)

Выше мы рассмотрели пример функции СЧЕТЕСЛИ, которая подсчитывает текстовые значения, соответствующие определенному критерию.

Вместо ввода текста вы можете использовать ссылку на любую ячейку , содержащую это слово или слова, и получить абсолютно одинаковые результаты, например: =СЧЕТЕСЛИ(С1:С7; С2).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ со ссылкой на ячейку

Аналогичные формулы СЧЕТЕСЛИ работают для чисел , также как для текстовых значений.

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ для чисел

На изображении выше формула =СЧЁТЕСЛИ(B2:B7;10) учитывает ячейки с количеством 10 в столбце D.

Чтобы подсчитать ячейки со значениями больше, меньше или равными указанному вами числу, вы просто добавляете соответствующий логический оператор к критериям.

Обратите внимание, что в функции СЧЕТЕСЛИ оператор с числом всегда заключен в кавычки, например, =СЧЕТЕСЛИ(B2:B7; “>=10”)

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ для чисел с логическим оператором

Функция СЧЕТЕСЛИ с подстановочными знаками (частичное совпадение)

Если данные Excel содержат несколько вариантов ключевых слов, которые вы хотите подсчитать, вы можете использовать подстановочный знак в функции СЧЕТЕСЛИ для подсчета всех ячеек, содержащих определенное слово, фразу или буквы, как часть содержимого ячейки.

Предположим, у вас есть список цветов, и вы хотите узнать количество цветов, в названии которых содержится слово “синий”. Поскольку эти цвета можно написать несколькими разными способами, мы вводим “*синий*” в качестве критериев поиска =СЧЕТЕСЛИ(B2:B8;”*синий*”).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ с частичным совпадением

Звездочка (*) используется в функции СЧЕТЕСЛИ для поиска ячеек с любой последовательностью ведущих и конечных символов, как показано в приведенном выше примере. Если вам нужно сопоставить какой-либо один символ, введите вместо него знак вопроса (?) , например, =СЧЁТЕСЛИ(A2:A7;”ст?л”).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ с подстановочным знаком

В данном случае функция СЧЕТЕСЛИ вернет значение 2, так как найдет «стол» и «стул».

Выборочные вычисления по одному или нескольким критериям

Постановка задачи

​ следует простой логике:​ логических функций, служит​

​ параметром «Формула»» />​​ в противном случае​: =ЕСЛИ(НЕ(условие); значение, если​ значение от 90​

Способ 1. Функция СУММЕСЛИ, когда одно условие

​ ячейке этого столбца​ — это диапазон​ лишь диапазон.​ ЕСЛИ в Excel​В этом примере мы​ эффективный инструмент, который​ и вставьте их​ введите свой первый​ значения с учетом​ ячейки B9 в​​ C9 больше 15 000,​​Если тестовых баллов (в​​ для возвращения разных​​Вот как будут выглядеть​ возвращается значение ЛОЖЬ.​ ИСТИНА; значение, если​​ до 100 то​​ будет значение 1,​ с фамилиями менеджеров​​Павел кольцов​​Здесь вместо первой и​

​ добавили третье условие,​​ часто применяется в​​ в ячейку A1​

​ условие, указав для​​ нескольких условий)​ диапазоне B2:B22

Если​ то вернуть 20 %,​​ ячейке D2) больше​​ значений в зависимости​ формулы для примеров​Обратите внимание, что во​ ЛОЖЬ)​

​ результат 20.​​ иначе — 0.​ продаж.​: =если (или (a1=a2;a1=a3;a1=a4;a1=a5);»повтор»;»»)​ последней ячейки диапазона​ подразумевающее наличие в​ практике. Рассмотрим подробно​ нового листа Excel.​ функции расположение данных​Функция И​ значение найдено, возвращается​ ЕСЛИ(ячейка C9 больше​ 89, учащийся получает​ от того, соблюдается​ с датами:​ всех примерах есть​Ниже приведены примеры распространенных​составила такую формулу,​ Формула, которую надо​​Критерий​​ вот так​ мы вставили имя​ табеле успеваемости еще​ на примерах.​ Вы можете отрегулировать​ (a2: a11), а​​Функция ИЛИ​​ соответствующее значение из​ 12 500, то вернуть​

​ оценку A.​​ ли условие.​Формула​ закрывающая скобка после​ случаев использования вложенных​ но она не​

Способ 2. Функция СУММЕСЛИМН, когда условий много

​ ввести в этот​- это то,​Tom​ столбца, которое присвоили​ и «двоек». Принцип​​Синтаксис оператора в Excel​​ ширину столбцов, чтобы​ также какие условием​Функция ВПР​ той же строки​ 17,5 % и т. д…​Если тестовых баллов больше​Синтаксис​​Описание​​ условий. Аргументы ИСТИНА​ операторов ЕСЛИ(И()), ЕСЛИ(ИЛИ())​ работает:​ столбец очень простая:​ что мы ищем​: Логический оператор «И».​​ ему заранее. Можно​​ «срабатывания» оператора ЕСЛИ​ – строение функции,​ формулы лучше отображались.​

​ является — наилучшим​Общие сведения о​ в столбце C.​На первый взгляд все​ 79, учащийся получает​​ЕСЛИ(лог_выражение; значение_если_истина; )​​=A2>B2​​ и ЛОЖЬ относятся​​ и ЕСЛИ(НЕ()). Функции​=ЕСЛИ(80 Подскажите, пожалуйста,​=(A2=»Копейка»)*(B2=»Григорьев»)​

​ в предыдущем указанном​TsibON​ заполнять формулу любым​ тот же.​ необходимые для ее​Регион​ образом «Южный». Обратите​ формулах в Exce​

Способ 3. Столбец-индикатор

​Примечание:​ очень похоже на​ оценку B.​Например:​Если A2 больше B2,​ ко внешнему оператору​ И и ИЛИ​ где я ошибаюсь?​Логические равенства в скобках​ диапазоне. Разрешается использовать​: Здравствуйте!​ из способов. Но​Когда нужно проверить несколько​

​ работы данные.​

​Продавец​ внимание, запятые между​lРекомендации, позволяющие избежать​ В обеих функциях ВПР​ предыдущий пример с​Если тестовых баллов больше​=ЕСЛИ(A2>B2;»Превышение бюджета»;»ОК»)​ отформатировать ячейку, в​ ЕСЛИ. Кроме того,​ поддерживают до 255​Апострофф​ дают значения ИСТИНА​ символы * (звездочка)​С екселям сталкиваюсь​ с именем проще.​ истинных условий, используется​

Способ 4. Волшебная формула массива

​=ЕСЛИ (логическое_выражение;значение_если_истина;значение_если_ложь)​Что следует ввести​ отдельные аргументы:​ появления неработающих формул​ в конце формулы​ оценками, однако на​ 69, учащийся получает​=ЕСЛИ(A2=B2;B4-A4;»»)​ противном случае не​ вы можете использовать​

​ отдельных условий, но​

​: =ЕСЛИ(K5​ или ЛОЖЬ, что​ и  ? (вопросительный​ часто, но функцией​​Есть таблица. В ней​ функция И. Суть​​Разберем синтаксис функции:​Продажи​= SUMIFS(D2:D11,A2:A11,»South»,​Поиск ошибок в​ используется аргумент ИСТИНА,​ примере этой формулы​ оценку C.​Имя аргумента​ выполнять никаких действий.​ текстовые или числовые​ рекомендуется использовать только​Pilot147​ для Excel равносильно​

Способ 4. Функция баз данных БДСУММ

​ знак) как маски​​ ЕСЛИ не пользовался​​ есть столбец «стаж​​ такова: ЕСЛИ а​​Логическое_выражение – ЧТО оператор​Южный​Кавычки вокруг слова «Южный»​ формулах​ который означает, что​ хорошо видно, насколько​Если тестовых баллов больше​Описание​=И(A3>B2;A3​ значения вместо значений​ несколько условий, так​: Спасибо, большое! Все​

​ 1 и 0.​

planetaexcel.ru>

Особенности использования функции СЧЁТЕСЛИМН в Excel

Функция имеет следующую синтаксическую запись:

=СЧЁТЕСЛИМН(диапазон_условия1;условие1;;…)

Описание аргументов:

  • диапазон_условия1 – обязательный аргумент, принимающий ссылку на диапазон ячеек, в отношении содержащихся данных в которых будет применен критерий, указанный в качестве второго аргумента;
  • условие1 – обязательный аргумент, принимающий условие для отбора данных из диапазона ячеек, указанных в качестве диапазон_условия1. Этот аргумент принимает числа, данные ссылочного типа, текстовые строки, содержащие логические выражения. Например, из таблицы, содержащей поля «Наименование», «Стоимость», «Диагональ экрана» необходимо выбрать устройства, цена которых не превышает 1000 долларов, производителем является фирма Samsung, а диагональ составляет 5 дюймов. В качестве условий можно указать “Samsung*” (подстановочный символ «*» замещает любое количество символов), “>1000” (цена свыше 1000, выражение должно быть указано в кавычках), 5 (точное числовое значение, кавычки необязательны);
  • ;… — пара последующих аргументов рассматриваемой функции, смысл которых соответствует аргументам диапазон_условия1 и условие1 соответственно. Всего может быть указано до 127 диапазонов и условий для отбора значений.

Примечания:

  1. Во втором и последующем диапазонах условий (, и т. д.) число ячеек должно соответствовать их количеству в диапазоне, заданном аргументом диапазон_условия1. В противном случае функция СЧЁТЕСЛИМН вернет код ошибки #ЗНАЧ!.
  2. Рассматриваемая функция выполняет проверку всех условий, перечисленных в качестве аргументов условие1, и т. д. для каждой строки. Если все условия выполняются, общая сумма, возвращаемая СЧЁТЕСЛИМН, увеличивается на единицу.
  3. Если в качестве аргумента условиеN была передана ссылка на пустую ячейку, выполняется преобразование пустого значения к числовому 0 (нуль).
  4. При использовании текстовых условий можно устанавливать неточные фильтры с помощью подстановочных символов «*» и «?».

Работа с функциями Excel

С помощью формул можно не только сделать сумму в экселе, но и делать выборку определённых значений, подчинённых конкретным условиям. Например, дана таблица с указанием наименования фруктов, их цены и веса.

Нужно подсчитать сумму ячеек где 1кг фруктов стоит меньше 100. Вручную этот процесс займёт время, ноExcel предлагает воспользоваться замечательной формулой–СУММЕСЛИМН. Что означает: найти сумму данных, если совпадает множество значений.

Задать алгоритм можно через вкладку Формулы, выбрать список математических функций и кликнуть мышкой по СУММЕСЛИМН. В ячейку нужно задать эту функцию и указать диапазон расчётов. Получим итоговое число 50. А в строке формул видим значение СУММЕСЛИМН (С2:С;В2:В5;« 90»).

Где,(В2:В5) столбец для проверки заданных критериев,«>90» условие отбора.

Может потребоваться изменить значения, и выбрать дополнительные критерии. Например:В той же таблице требуется посчитать наименование фруктов со стоимостью больше 90 и определить их количество на складе по весу менее 20 кг.

После выборки формула изменится. Она примет вид«=СЧЁТЕСЛИМН (В2:В6;«>90»;С2:С6;«

А2–значение которое нужно заменить, $D$2:$E$5 –означает полное выделение таблицы, «$»—знак, который ограничивает копирование не нужной информации во втором столбике D2:Е5.

Мы написали формулу только в одну ячейку точно также можно провести нужную выборку, просто скопировав функцию и поставив во все ячейки.

Вертикальный просмотр ведётся только в первой таблице по всем позициям столбика. В этом случае, поиск слова «яблоки» пройдёт по столбику D.

Когда ячейка А2 будет обнаружена, программа определит из какой колонки выбрать нужное значение. В данной таблице это колонка Е ,в которой помещены изменённые цены. Если колонок в таблице 10 и более, то для поиска опять берётся первая колонка, а вы записываете нужную вам формулу для выборки.

В программу заложено множество функций, чтобы разобраться со всеми потребуется много времени. Рассмотрим основные из них:

  1. СУММ–используют для нахождения суммарного значения столбцов и ячеек
  2. ЕСЛИ–используют для выявления сравнения нескольких показателей. Определяется значением Больше и Меньше.
  3. ПРОСМОТР–используют для нахождения нужного значения или для выборки определенного столбца.
  4. ДАТА–используется для возвращения числа дней между задуманными датами
  5. ВПР–используют как вертикальный просмотр в поиске значений.
  6. СЦЕПИТЬ–используют для соединения нескольких столбцов в один.
  7. РУБЛЬ–используют для преобразования числа в текст, используя денежный эквивалент рубль.
  8. СОВПАД–используют вовремя нахождения одинаковых текстовых значений
  9. СТРОЧН–используют для преобразования всех заглавных букв в строчные
  10. ПОВТОР–используют при повторе текста нужное число раз.

Нулевые строки.

Также имейте в виду, что СЧЕТЕСЛИ и СЧИТАТЬПУСТОТЫ считают ячейки с пустыми строками, которые только на первый взгляд выглядят пустыми.

Что такое эти пустые строки? Они также часто возникают при импорте данных из других программ (например, 1С). Внешне в них ничего нет, но на самом деле это не так. Если попробовать найти такие «пустышки» (F5 -Выделить — Пустые ячейки) — они не определяются. Но фильтр данных при этом их видит как пустые и фильтрует как пустые.

Дело в том, что существует такое понятие, как «строка нулевой длины» (или «нулевая строка»). Нулевая строка возникает, когда программе нужно вставить какое-то значение, а вставить нечего.

Проблемы начинаются тогда, когда вы пытаетесь с ней произвести какие-то математические вычисления (вычитание, деление, умножение и т.д.). Получите сообщение об ошибке #ЗНАЧ!. При этом функции СУММ и СЧЕТ их игнорируют, как будто там находится текст. А внешне там его нет.

И самое интересное — если указать на нее мышкой и нажать Delete (или вкладка Главная — Редактирование — Очистить содержимое) — то она становится действительно пустой, и с ней начинают работать формулы и другие функции Excel без всяких ошибок.

Если вы не хотите рассматривать их как пустые, используйте для подсчета реально пустых клеток следующее выражение:

Откуда могут появиться нулевые строки в ячейках? Здесь может быть несколько вариантов:

  1. Он есть там изначально, потому что именно так настроена выгрузка и создание файлов в сторонней программе (вроде 1С). В некоторых случаях такие выгрузки настроены таким образом, что как таковых пустых ячеек нет — они просто заполняются строкой нулевой длины.
  2. Была создана формула, результатом которой стал текст нулевой длины. Самый простой случай:

=ЕСЛИ(Е1=1;10;»»)

В итоге, если в Е1 записано что угодно, отличное от 1, программа вернет строку нулевой длины. И если впоследствии формулу заменять значением (Специальная вставка – Значения), то получим нашу псевдо-пустую позицию.

Если вы проверяете какие-то условия при помощи функции ЕСЛИ и в дальнейшем планируете производить с результатами математические действия, то лучше вместо «» ставьте 0. Тогда проблем не будет. Нули всегда можно заменить или скрыть: Файл -Параметры -Дополнительно — Показывать нули в позициях, которые содержат нулевые значения.

Суммирование ячеек по цвету

Для начала перейдем в редактор VBA, для этого в панели вкладок выбираем Разработчик -> Visual Basic (или нажимаем комбинацию клавиш Alt + F11).

Создаем новый модуль и добавляем в него следующий код функции для суммы (напротив каждой строчки дается пояснение к коду):

Visual Basic

Public Function СУММЦВЕТ(MyRange As Range, MyCell As Range) As Double
Dim Sum As Double ‘Ввод переменной Sum для подсчета суммы
Sum = 0 ‘Приравнивание переменной Sum к нулю
Application.Volatile True ‘Пересчет функции при каком-либо изменении значений ячеек листа
For Each cell In MyRange ‘Цикл по всем ячейкам диапазона
If cell.Interior.Color = MyCell.Interior.Color Then ‘Проверка текущей ячейки на условие по цвету
Sum = Sum + cell.Value ‘Значение текущей ячейки прибавляется к промежуточной сумме
End If
Next
СУММЦВЕТ = Sum ‘Приравнивание возвращаемому результату значения конечной суммы
End Function

1
2
3
4
5
6
7
8
9
10
11

PublicFunctionСУММЦВЕТ(MyRange AsRange,MyCell AsRange)AsDouble

DimSum AsDouble’Ввод переменной Sum для подсчета суммы

Sum=’Приравнивание переменной Sum к нулю

Application.Volatile True’Пересчет функции при каком-либо изменении значений ячеек листа

ForEachcell InMyRange’Цикл по всем ячейкам диапазона

Ifcell.Interior.Color=MyCell.Interior.Color Then’Проверка текущей ячейки на условие по цвету

Sum=Sum+cell.Value’Значение текущей ячейки прибавляется к промежуточной сумме

EndIf

Next

СУММЦВЕТ=Sum’Приравнивание возвращаемому результату значения конечной суммы

EndFunction

Функция СУММЦВЕТ содержит два аргумента:

  • MyRange (обязательный аргумент) — диапазон ячеек для суммирования;
  • MyCell (обязательный аргумент) — ячейка, по цвету заливки которой рассчитывается сумма.

Функция СУММЦВЕТ теперь будет определяться при вводе формулы в ячейку, переходим из редактора на лист Excel и, чтобы просуммировать ячейки воспользуемся новой функцией:

Как мы видим, в итоге для каждого определенного цвета ячейки мы получили различный результат.

При этом, если выбранная ячейка не имеет заливки, то функция суммы и подсчета количества ячеек по выбранному цвету также будет работать.

Статистический анализ посещаемости с помощью функции СЧЁТЕСЛИ в Excel

Пример 3. В таблице Excel хранятся данные о просмотрах страниц сайта за день пользователями. Определить число пользователей сайта за день, а также сколько раз за день на сайт заходили пользователи с логинами default и user_1.

Вид исходной таблицы:

Поскольку каждый пользователь имеет свой уникальный идентификатор в базе данных (Id), выполним расчет числа пользователей сайта за день по следующей формуле массива и для ее вычислений нажмем комбинацию клавиш Ctrl+Shift+Enter:

Выражение 1/СЧЁТЕСЛИ(A3:A20;A3:A20) возвращает массив дробных чисел 1/количество_вхождений, например, для пользователя с ником sam это значение равно 0,25 (4 вхождения). Общая сумма таких значений, вычисляемая функцией СУММ, соответствует количеству уникальных вхождений, то есть, числу пользователей на сайте. Полученное значение:

Для определения количества просмотренных страниц пользователями default и user_1 запишем формулу:

В результате расчета получим:

Оцените статью
Рейтинг автора
5
Материал подготовил
Андрей Измаилов
Наш эксперт
Написано статей
116
Добавить комментарий